25 сентября на сервере PLUTON с 15:14 по 17:56 на сайтах наблюдались периодические 502 ошибки из-за сбоя в работе веб сервера Apache. По какой-то причине процессы стали завершаться с предупреждениями [notice] child pid 2351586 exit signal Segmentation fault (11), которые сами по себе не предоставляют никакой ценной информации.
Ситуация была усугублена тем, что ошибки были не постоянные, по этой причине мониторинг сработал только в 17:50, когда получил 3 ошибки подряд. После перезагрузки веб сервера ошибки пропали.
Причины произошедшего на данный момент неизвестны, мы перенастроили веб сервер для сбора отладочной информации, только при повторном сбое мы сможем найти проблемный участок и принять какие-то меры. Чтобы более оперативно среагировать на подобный сбой мы доработали систему мониторинга для поиска указанных выше ошибок в журнале веб сервера.
Приносим извинения за доставленные неудобства, при приложим максимум усилий для устранения причин подобных сбоев.
По состоянию на 28 сентября мы обновили модуль передачи реальных IP-адресов от Nginx к Apache, предположительно проблема была из-за него (ранее сталкивались с подобной проблемой на сервере ORION). Режим отладки отключим только через 30 дней отсутствия проблем.